We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Why tag->setDefault automatic convert unicode utf-8 text to unicode decmal

I'm new to Phalcon PHP and i'm testing Vietnamese characters and stuck at these. I use utf-8 to store text on db, on edit form Phalcon copy to setDefault and automatic convert utf-8 text to unicode decimal likes this.

In controller: $text = " â Ă ă Ð đ Ĩ ĩ Ũ ũ Ơ ơ Ư ư Ă ă Ạ ạ Ả ả Ấ ấ Ầ ầ Ẩ ẩ Ẫ ẫ Ậ ậ Ắ ắ Ằ ằ Ẳ ẳ Ẵ ẵ Ặ ặ Ẹ ẹ Ẻ ẻ Ẽ ẽ Ế ế Ề ề Ể ể Ễ ễ Ệ ệ Ỉ ỉ Ị ị Ọ ọ Ỏ ỏ Ố ố Ồ ồ Ổ ổ Ỗ ỗ Ộ ộ Ớ ớ Ờ ờ Ở ở Ỡ ỡ Ợ ợ Ụ ụ Ủ ủ Ứ ứ Ừ ừ Ử ử Ữ ữ Ự ự Ỳ ỳ Ỵ ỵ Ỷ ỷ Ỹ ỹ"; $this->tag->setDefault("fullname",$text );

the output HTML is automatic converted into: <input size="30" name="fullname" id="fullname" value=" � Ă ă � đ Ĩ ĩ Ũ ũ Ơ ơ Ư ư Ă ă Ạ ạ Ả ả Ấ ấ Ầ ầ Ẩ ẩ Ẫ ẫ Ậ ậ Ắ ắ Ằ ằ Ẳ ẳ Ẵ ẵ Ặ ặ Ẹ ẹ Ẻ ẻ Ẽ ẽ Ế ế Ề ề Ể ể Ễ ễ Ệ ệ Ỉ ỉ Ị ị Ọ ọ Ỏ ỏ Ố ố Ồ ồ Ổ ổ Ỗ ỗ Ộ ộ Ớ ớ Ờ ờ Ở ở Ỡ ỡ Ợ ợ Ụ ụ Ủ ủ Ứ ứ Ừ ừ Ử ử Ữ ữ Ự ự Ỳ ỳ Ỵ ỵ Ỷ ỷ Ỹ ỹ" type="text" />

How to turn off this feature.

Thanks



98.9k
Accepted
answer

Try Phalcon\Tag::setAutoescape(false);

That works greate. Thanks