Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon 3.0 ./install detects other php version

I recently updated to php7 and I'm triying to build phalcon again. But when I execute ./install it keeps taking the php 5 version. If I check the loaded one: php -i | grep Loaded it says Loaded Configuration File => /etc/php/7.0/cli/php.ini or php -v wich says v7.0.9-1~dotdeb+8.1

although ./install takes the previous 5.6

PHP Api Version:         20131106
Zend Module Api No:      20131226
Zend Extension Api No:   220131226

I deleted the old php to be sure. And now the error is: php-config is not installed Checking for the php7.0 repo can't see any php-config. Any clue?


have you installed php7.0-dev?

edited Aug '16

Great, I installed php7.0-dev and the build was created for my new php 7. But now, after adding the to the extensions my php-fpm does not start.

sudo service php7.0-fpm start
Job for php7.0-fpm.service failed.

I have pointed the extension to the absolute path too, but same behaviour: extension=/usr/lib/php/20151012/

It starts ok without the nothing appears on my php-fpm error log :( only sucessfull starts without extension:

 NOTICE: fpm is running, pid 21991
 NOTICE: ready to handle connections
 NOTICE: systemd monitor interval set to 10000ms
 NOTICE: Terminating ...
 NOTICE: exiting, bye-bye!
edited Aug '16

It seems to be related to loaded before jsonserializable I added /etc/php/7.0/fpm/conf.d/phalcon.ini with and everything works ok.