Invo tried to add one more private resource

I have added one more private resource (say manage faq feature) in the ACL.

But its not allowing me to access it even if I am logged in.

$privateResources = array(
                'companies' => array('index', 'search', 'new', 'edit', 'save', 'create', 'delete'),
                'products' => array('index', 'search', 'new', 'edit', 'save', 'create', 'delete'),
                'producttypes' => array('index', 'search', 'new', 'edit', 'save', 'create', 'delete'),
                'faqs' => array('index', 'search', 'new', 'edit', 'save', 'create', 'delete'), //new private resource
                'invoices' => array('index', 'profile')

New Private resource faqs is returning false when check for ACL: php $allowed = $acl->isAllowed($role, $controller, $action);

Do I have to clear any type of cache?

Kindly help on how to proceed from this point.

I got it. The issue lies with php if (!isset($this->persistent->acl)) { As I have added a new module, the old acl setting persisted. I removed the condition and re-run it and got the issue solved.