"php-config" not found in php7 CentOS

Hi guys, I'm startin with phalcon and make some projects in localhost, but i can't install phalcon. When I run ./install response to me this "php-config command not found" I search so much in web for fix this but dont find anything. Someone know how i can fix? Regards

php7-dev installed ?



1.0k

I faced the same problem. :(

php7-dev installed ?

Can you help me with the installation?

$ sudo apt install php7.2-dev 
...
The following packages have unmet dependencies:
 php7.2-dev : Depends: libpcre3-dev (>= 2:8.35) but it is not going to be installed
              Depends: libssl-dev but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
$ sudo apt install libpcre3=2:8.35
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Version '2:8.35' for 'libpcre3' was not found

What can i do? Thank you.



1.0k

I tried a different installation way.

$ curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh | sudo bash
Detected operating system as LinuxMint/tara.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/phalcon_stable.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.

But after updating the repository, I get an error.

$ sudo apt update
...
Hit:19 https://repo.skype.com/deb stable InRelease                                                        
Ign:20 https://packagecloud.io/phalcon/stable/linuxmint tara InRelease                             
Err:22 https://packagecloud.io/phalcon/stable/linuxmint tara Release          
  404  Not Found [IP: 52.8.147.134 443]
Reading package lists... Done                       
E: The repository 'https://packagecloud.io/phalcon/stable/linuxmint tara Release' does not have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.