Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

ERROR: Your Phalcon version isn't compatible with Developer Tools

Hello, please i'm very new to Phalcon but i'm having issues setting up my development environment.

I have followed the instructions given here for OSX however i noticed using brew installs Phalcon 2.0.13 and i cannot understand why this is so.

I followed this guide on installing dev tools but i keep getting "ERROR: Your Phalcon version isn't compatible with Developer Tools, download the latest at:" when i run "phalcon" from the terminal.

Please how can i resolve this issue.

Thank you.

Latest devtools are for 3.0.x.


Thanks. I earlier got the information that brew installation doesn't have phalcon 3 and that was the major reason i was experiencing the issue. So i learnt i have to compile from source code if i need to install phalcon 3. @Wojciech, thanks for sharing your knowledge.