We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

APC cache incomplete modelsMetadata when memory is full

after i switch caching metadata from Phalcon\Mvc\Model\Metadata\Memory to Phalcon\Mvc\Model\Metadata\Apc, it shows some columns do not belong to this model. i try to dump metadata both apc and memory and found apc miss some columns. after i clear apc cache, and it works.....

so.... is this a bug? the follwing is my apc.ini configuration

apc.ttl     7200
apc.user_ttl    7200
apc.gc_ttl      0  <= will it be cause the problem?


I'm sorry. I found the problem. i have two projects using the same prefix and table name. one is for the api, another is for the backend. The api define less columns(metadata), and that's why it sometimes works(get another cached metadata)