Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon\Mvc\Model BUG??? [solved - not bug]


Why the error occurred???

Scanning error before 'Vokuro\Models\Re...' when parsing: SELECT [Vokuro\Models\Ref\СurrencyСodes].* FROM [Vokuro\Models\Ref\СurrencyСodes] (85)


namespace Vokuro\Models\Ref;

use \Phalcon\Mvc\Model;

 * СurrencyСodes
class СurrencyСodes extends Model
    public function getSource()
        return 'currency_codes';

    public function getSchema()
        return 'ref';

CREATE TABLE currency_codes ( id integer NOT NULL, alpha_3 character(3) NOT NULL, "numeric" smallint NOT NULL, description character varying(255) NOT NULL );


Problem solved. Was somewhere a syntax error, which I never found (found, in my Cyrillic character "C" was in the class name and the file name). It was decided to delete all and re-create the table and model.