We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Job for php7.1-fpm.service failed because a fatal signal


I wanted to install Phalcon for the first time to play around with it. But I'm having some trouble with adding the phalcon extension to my php installation.

When I only follow the installation instructions about the Ubuntu package (I wasn't sure if I needed to do the rest) I do see the XX-phalcon.ini beeing mentioned in my phpinfo but the phalcon extension itself is not mentioned on the page.

curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh | sudo bash
sudo apt-get install php7.0-phalcon

I restarted php-fpm after this.

Because it was unclear to me if I needed to perform one of the other installation instructions, I also run the GIT related commands.

git clone --depth=1 git://github.com/phalcon/cphalcon.git
cd cphalcon/build
sudo ./install

After de installation completed I again tried to restart php-fpm but got een error:

Job for php7.1-fpm.service failed because a fatal signal was delivered causing the control process to dump core. See "systemctl status php7.1-fpm.service" and "journalctl -xe" for details.

When running the journalctl -xe command the following output is visible:

-- Unit php7.1-fpm.service has begun starting up. Jan 06 22:31:49 homestead kernel: show_signal_msg: 12 callbacks suppressed Jan 06 22:31:49 homestead kernel: php-fpm7.1[29556]: segfault at a00000001 ip 0000564bfb2ca3e0 sp 00007ffccf059df0 error 6 in php-fpm7.1[564bfb029000+3cc000] Jan 06 22:31:52 homestead systemd[1]: php7.1-fpm.service: Main process exited, code=dumped, status=11/SEGV Jan 06 22:31:52 homestead sudo[29548]: pam_unix(sudo:session): session closed for user root Jan 06 22:31:52 homestead systemd[1]: Failed to start The PHP 7.1 FastCGI Process Manager. -- Subject: Unit php7.1-fpm.service has failed

I'm trying to install Phalcon on a Laravel homestead Vagrant box which is running on Ubuntu 16.04 and PHP 7.1. I hope I provided enough information to solve my installation issues.

I hope the problems can be easly solved so I can disocver the power of Phalcon :)


phalcon does support php 7.1 yet

Thank you! I was afraid that was the issue. I downgraded to PHP 7.0 and it works.

phalcon does support php 7.1 yet