Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

- %1 Error installing Phalcon

Sorry I'm new to phalcon but I'm getting a PHP Startup error. I followed the XAMPP installation guide for windows but whenever I run the apache server I'm getting the following error:

PHP Startup: Unable to load dynamic library '/file location' - %1 is not a valid Win32 application.

As on the guide:

I placed the php_phalcon.dll in the php/ext folder php.ini last line -> extension=php_phalcon.dll

Thanks for reading.


Check that you're using the right DLL for your architecture x86_32 or x86_64:


Also be sure to check NTS flag...I got first the NTS version which didn't work...finally the version without NTS worked on my XAMPP

Which build of Bitnami you were using? I am experirencing the same issues with wappstack-5.5.15-0.


Hi I am new to Phalcon, I am getting Same error message though I used Correct version of the dll. II am geting this "php startup unable to load dynamic library [ location / ] phalcon.dll "

What is the reason ?

I succeded to solve it with using the 32bit extension on a 64bit enviornment. Very strange, but it worked that way for me.