Installation failed

Hi everyone,

I tried to install Phalcon on CentOS 6.5. This is what I did:

o Edit etc/yum.conf: remove the line ‘exclude=’ (temporarily) o Terminal:

  • Sudo yum update (to update everything on the system)
  • Yum install php-devel
  • Sudo yum install git
  • git clone git://
  • cd cphalcon/build
  • sudo ./install o Add a file called phalcon.ini in /etc/php.d/ with this content: o Put back the original etc/yum.conf file o Restart server.

Before I rebooted the server, "Apache is functioning normally" was displayed when I typed the IP address in my browser. Now when I got there, I get a browser message about being unable to establish a connection. When I type :2222 after the ip address, I can get access to directadmin.

What did I do wrong? (this is the second time I tried to reinstall it completely...)

Thank you very much

What were the results of your ./install?

There were no errors during the installation + gcc was already installed

I do not have the exact results anymore, I can reinstall it and post the results here if that will help?

Does it show up in here? (Same as doing phpinfo() on a page)

$ php -i | grep phalcon

Hmm that doesn't return anything

I must have missed some errors during the installation then?

Did you reload apache? And are you sure the phalcon extension is in the php.ini?


I included the extension directly in my php.ini with the full path to After I rebooted my server and phalcon was enabled. (CentOS 6.5) hope it will help.

Thanks for your support :) I think something goes wrong when I install php-devel, so I'll head to a centos forum to ask what might go wrong there (I rebooted after each step to figure out when it would stop saying apache is working). I'll have to figure out that error first before I can continue the Phalcon installation.