We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

Phalcon webtools doesn't work


First I use shared cpanel hosting to which I have SSH access.

I installed phalcon devtools and everything worked normally.

I want to run webtools, I released them but when I try to access webtools.php I load the index controller.

I have added my IP address to webtools config. The project is modular - backend and frontend.

Where can the reason why my webtools.php does not load me?


seeing index controller could be

  1. Route does not exists
  2. Your apache/nginx is not configured properly

p.s. може да ме намериш в дискорда на phalcon https://discordapp.com/invite/kRc2N2M ( izo )

edited Nov '17

webtools.php is meant to be accessed from your web browser and is supposed to be located in your web application's root if it's installed properly. If it's below your web root, trying to access webtools.php will just act like any other 404 page. You'll need to debug a bit to figure out what is and isn't the problem. Comment some things out, and put them back until you discover the line of code it's choking on. Verify you can have your webtools.php run when everything is commented out. then uncomment one line at a time until it breaks. Then track anything it requires and do the same thing. If webtools.php, when everything is commented out, still loads your application's index controller, then your problem is with your apache or nginx configuration.

As mentioned earlier in Discord, webtools.php expects three things:

A .phalcon directory in your application root, where it can log and cache things.

A config with one of the following names:


stored in one of the following directories:


And a webtools.config.php file to sit along side the webtools.php file.

You'll need to configurate webtools.config.php, and verify what works and what doesn't.

BASE_PATH and APP_PATH are pretty high priority to make sure you configured right for your application structure.
Do some echo's to verify you've set things to the correct value.

Do some debugging and get back to us with more information regarding what you tried. Some information regarding your PHP setup and whether you're trying this locally, or on a web server would help. I don't understand what "shared cpanel hosting to which I have SSH access" means. Does this mean you're on a shared host? A VPS server? or Dedicated server?

What kind of server is it,what version of PHP are you running, and what version of Phalcon are you running? You can obtain this information with a phpinfo.php file set to <?php phpinfo(); ?> and accessing it from your website's web root, the same place you should be placing webtools.php.

If you have any success, you should see a User Interface similiar to the following:

What is frustrating to us adoptive parents is that people don't seem to respect the same boundaries with us as they do with other people. I don't ask new moms how much of their hospitalization was covered by insurance, yet people found it acceptable to ask me how much my baby cost.

The Single Sibling GPS: It Will Save Your Marriage! When to Unplug: Consulting User-Generated Review Sites to Plan the Perfect Date