MSSQL Model->save() = false But No error

As the title says, i know MSSQL is not officially supported by Phalcon, but i made the necessary changes to get it up and running with dblib.

Now when i try to update a record, it saves and updates correctly in the db, but the save method returns false. No messages are shown though.

I tried removing all validators, and set all columns to nullable to make sure its not an automatic validation but still no luck.

Any idea what could be causing the problem?

Hi @mnashmi I was looking in the incubator repo and I found an Oracle adapter and looks pretty simple to do

Probably If you have the knowledge about MSSQL make an adapter and then share whith us. Ademas you have to do an Dialect MSSQL. Look Oracle Dialect Class

Documentation about DB Layer

Good luck

And when you go with raw PDO - it works all good?

@mnasmi did you tried?

if ($robot->save() === false) {
   echo "Umh, We can't store robots right now: \n";

   $messages = $robot->getMessages();

   foreach ($messages as $message) {
      echo $message, "\n";