We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

Strange behaviour of phalcon devtools

I downloaded phalcon devtools from github and followed the instructions but when I run a command like 'phalcon controller classname' I am asked for the directory name. When I specify it, I am told that .phalcon folder is absent and whether it should be created or not. When I choose yes, it exits with an error.

I tried deleting the symlink with rm command but I am stock with this error

' Your environment variable $PTOOLSPATH is outdated! Current value: /Downloads/phalcon-devtools-master New value: /phalcon-devtools-master Exit. ' How do I go about it?

I did not have this issues on windows 10. I currently have all these issues with phalcon devtools on ubuntu 16



I am told that .phalcon folder is absent

usually that happens when you're runnig devtools outside an existing phalcon project.

First create project: phalcon project myproject go into it: cd mycproject then you should be able to use devtools

Wherefrom did you run command? You can run command either from base project path or set directory.


Thank guys. I finally resolved the problem. I had to make use of the output flag and not directory in my command.