Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Installation seem impossible on Mac – what to do?

I've spent the last couple of days trying to install this framework. There seem to be A LOT of obstacles in the process ... missing gcc compiler, read/write access issues and what have you [ insert a lot of wasted time here ]. I finally managed – after installing MacPorts, and through that a gcc47 compiler – to create the extension (even though it couldn't install due to access denied errors, and yes – this was all done while logged in as root, and running commands with sudo). I manually added the extension to my PHP extentions directory, added the .so extension to my php.ini file, restarted MAMP Servers, to no avail (for the 117th time).

I saw a guy who compiled for at couple of versions of PHP. Now, why isn't it that 'some guy' simply compiled a for the latest version of PHP of the major (or even minor) platforms, for others to simply download (I'm not talking production server versions, as that may be to specific), but simply for others to test the framework. Now, I have to leave this framework behind, as I have 'stuff to do', and simply cannot afford to spend days trying to get things up and running.

Now, MAMP is a reality (we're talking Apache, PHP and MySQL – a package of three fairly complex pieces of software in ONE PACKAGE). Couldn't this be done for this SINGLE EXTENSION, to make it easier getting started?

[ Leaning back, awaiting flaming : ) ]


Finally! This post made the difference.

Besides all the other missing parts I fixed during the process, the pointing to the right PHP version made the difference!

I obviously had to make a post here first to make it work : )