We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Can't upgrade to 1.3.x

I'm using 1.2.6 on ubuntu 12.04 LTS 64bit, php5 5.3.10 package version

After downloading master through git, I can't upgrade it owing to the following error, so I returned to 1.2.6.

Phalcon's path is /usr/local/src/git/cphalcon.

Why cannot I upgrade?

config.status: executing libtool commands
/bin/bash /usr/local/src/git/cphalcon/build/64bits/libtool --mode=compile gcc  -I. -I/usr/local/src/git/cphalcon/build/64bits -DPHP_ATOM_INC -I/usr/local/src/git/cphalcon/build/64bits/include -I/usr/local/src/git/cphalcon/build/64bits/main -I/usr/local/src/git/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DPHALCON_RELEASE -DHAVE_CONFIG_H  -march=native -mtune=native -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden   -c /usr/local/src/git/cphalcon/build/64bits/phalcon.c -o phalcon.lo 
libtool: compile:  gcc -I. -I/usr/local/src/git/cphalcon/build/64bits -DPHP_ATOM_INC -I/usr/local/src/git/cphalcon/build/64bits/include -I/usr/local/src/git/cphalcon/build/64bits/main -I/usr/local/src/git/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DPHALCON_RELEASE -DHAVE_CONFIG_H -march=native -mtune=native -O2 -finline-functions -fomit-frame-pointer -fvisibility=hidden -c /usr/local/src/git/cphalcon/build/64bits/phalcon.c  -fPIC -DPIC -o .libs/phalcon.o
/tmp/cc21SKQq.s: Assembler messages:
/tmp/cc21SKQq.s:281819: Error: no such instruction: `vfmadd312sd .LC2006(%rip),%xmm0,%xmm1'
make: *** [phalcon.lo] Error 1


98.9k
Accepted
answer

Try:

git clone https://github.com/phalcon/cphalcon
cd cphalcon/build/64bits
export CFLAGS="-O2 -fvisibility=hidden"
./configure --enable-phalcon
make
sudo make install


2.6k

Great! Thank you very much!

I am also having the same issue on ubuntu 12.04 LTS 64bit, php5 5.5.10. The options provided above in CFLAGS are in the default options already. Is there a better fix?