Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Empty Model::findFirst($id) with existing Database Entry - PDO works

Hi there,

while trying to get an Db Entry with Model::findFirst() it returns false even though the sql.log shows the right query.

Di::getDefault()['db']->query('SELECT * FROM model LIMIT 1')->fetchAll() returns the correct result.

When assigning those results to Model and doing a setFoo('bar')->save(), DB is untouched.

Can anybody help me here??


hi @holgersielaff check your model source setSource() and getSource(). docs

Tip: better use Model::findFirst(['conditions' => 'id = {id:int}', 'bind' => ['id' => $id]]); instead of Model::findFirst($id)

Good luck

Posting the (relevant) source of your model class could help... Also, which version of PHP + Phalcon are you running?

Hi all and thank you for the replies,

my system specs (Dockerfile) are:

FROM ubuntu:bionic
RUN DEBIAN_FRONTEND=noninteractive apt-get install -y --no-install-recommends \
    apache2 \
    php-fpm \
    php-mysql \
    curl \
RUN  curl -s "" | bash && apt-get install -y --no-install-recommends php7.2-phalcon
RUN a2enmod rewrite headers proxy_fcgi

Database is mounted via -v /var/run/mysql/mysql.sock:/var/run/mysql/mysql.sock

Models are generated via phalcon-devtools (--get-set --abstract)

Does this help?



Hi all,

i solved it by setting

"options" => [

in db config

Thanks, Holger