We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

50-phalcon.ini missing on Apache2/FPM (Ubuntu 18.04)

Hello everyone,

I'm trying to install Phalcon PHP on Apache2/FPM (Ubuntu 18.04) and I need some help. I've tried to install but nothing. Then i decided to get source code, compile and install. But nothing. Symlinks are OK for CLI, Apache2 and PHP-Fpm. Only .INI of Phalcon.so is not loaded. I tried to insert the absolute path of phalcon.so in the .INI file, but nothing. Can anyone help me? My Apache Server API is FPM/FastCGI.


Hi Jonathan,

I have also tried with packagecloud and Github. Compiling and installation are OK. What's happening?

Hi Jonathan,

i have PHP Version 7.2.10-0ubuntu0.18.04.1. To test, i have tried to update it with ppa:ondrej/php repository. With these packages Phalcon is started. Why?

Check this page :-) for the right location and content for the 50-phalcon.ini file (here named as 30-phalcon.ini)


echo "extension=phalcon.so" > /etc/php7/conf.d/30-phalcon.ini