Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Can't upgrade 1.2.6 to 1.3.*

Hello, My project works perfect with Phalcon v 1.2.6, then I recompile phalcon and I got phalcon 1.3.1 succesfully, restarted apache... But when enter on my project POST request doesn't work (302 error). Do I need to change something on my project?

What do you do in action which makes error?
Database operations?
If yes then you have to load phalcon extension after PDO extension

So i think that it is probably the same case


I found the problem, I used to set a session variable with a user object taken from the model.It seems that this doesn't work on phalcon 1.3.*

show my your php code

Same problem here. It's broken in 1.3.1 (ext/kernel/memory.c): Error message: "Cannot use the memory manager when the request is shutting down." from phalcon_memory_grow_stack

edited Mar '14

Having the same problem and I'm doing the same thing as almaro90, that is saving a model object into the session, like this

$user = User:find(anything);
$this->session->set("user", $user);

The error only happens after the html is built and output to the browser (the fatal error appears at the bottom of the page if I enable display_errors), so nothing breaks