Packagecloud for Fedora 29 not working

I'm on Fedora 29 and when I run the script provided on the installation page, it doesn't actually install the repo correctly and it doesn't find pygpgme because fedora 29 has it listed as gpgme and throws fun errors.

So the command installs yum-utils when it should probably install dnf-utils for fedora 29. When it does install the repos in /etc/yum.repos.d/phalcon_stable.repo it has these urls listed$basearch

In my case $basearch evaluates to x86_64 and that url doesn't seem to lead anywhere.

When I go to run dnf search phalcon or yum search phalcon nothing comes up or shows up.

I'll try installing by source and see how that goes.

Any guidance is appreciated. Thanks!

Well that's the latest distro release - is it LTS? You'd better fire up a VM/container with a supported distro/version if you're developing a project.


Yeah I just compiled it from source after adding every PSR package in dnf and then installing that php-psr package extension from github. Something's wrong with it cause the router is broken with displaying "Wrong number of parameters" everywhere and Phalcon is a beast to debug :-/ It works on my site running on CentOS 7, looks like I can't build it for Fedora.

You're using 3.4.x LTS release, right?


I was using 4.0.0 then I rebuilt it under 3.4.x with the same result.

Well 4.0.x release is in it's infancy - alpha stage and thus shall not be used for production. Stick with 3.4.x release. Like I said - just use a supported distro. FIre up a VM/machine container for developoment.