Running on vagrant ubuntu 16.04, Im getting error on installation for PHP7.3

Did not experience this before on PHP7.0, but when I try on a box ubuntu 16.04 and the latest PHP7.3, I get this error:

This is what I did for copying phalcon source

git clone https://github.com/phalcon/cphalcon

And then I get this error

[email protected]:~/cphalcon/build$ sudo ./install

./install: line 66: --version: command not found php-config is not installed

Here are the packages installed

[email protected]:~/cphalcon/build$ sudo apt-cache pkgnames | grep php7.3

php7.3-xml php7.3-xsl php7.3-xmlrpc php7.3-zip php7.3-mbstring php7.3-readline php7.3-tidy php7.3-pspell libphp7.3-embed php7.3-recode php7.3 php7.3-json php7.3-mysql php7.3-gd php7.3-curl php7.3-ldap php7.3-imap php7.3-sqlite3 php7.3-common php7.3-intl php7.3-odbc php7.3-bcmath php7.3-opcache php7.3-bz2 php7.3-cgi php7.3-cli php7.3-snmp php7.3-dba php7.3-dev php7.3-soap php7.3-fpm php7.3-gmp php7.3-sybase php7.3-interbase php7.3-phpdbg libapache2-mod-php7.3 php7.3-pgsql php7.3-enchant

Anyone encountered this? whats the workaround on this, thanks in advance



3.9k

I have tried this other method of installation and it seems to work. Is this method good enough?

curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh | sudo bash

sudo apt-get update

sudo apt-get install php-phalcon

when I ran the phalcon version I get version 3.4.2

[email protected]:/$ php -r "echo Phalcon\Version::get();"
3.4.2 [email protected]:/$