Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Problem installing on Maverick with HomeBrew

Hi there,

I've just installed Phalcon for PHP 5.4 on my Mavericks MacBook Pro using Homebrew. Contrary to what the documents said:

sudo brew install php54-phalcon

I didn't use "sudo" because when I did, HomeBrew refused to do its thing! :)

Everything seemed to install OK but when I run PHP -i from the command line, Phalcon isn't loading.

Any ideas?



Did you add to the php.ini?


Did you run 'brew link php54' before?

It could be that the php that you were call for the command line is the one that came with Mavericks and not the one compiled by Homebrew.


Hey Guys, thanks for your advice!

@Mellisa P - you were absolutely right. I had no idea that HomeBrew had/would install PHP and I only installed HomeBrew to install Phalcon. I thought that it would just work against the Mavericks PHP installation. So, I've created a symlink pointing the Mavericks PHP to the HomeBrew PHP, and when I ran "php -i" on the command line, sure enough, Phalcon is listed as an installed extension! :)

Really excited about Phalcon so was keen to resolve this small issue. Thank you both once again :D