Update to Phalcon 4

Hi everyone, I'm tryng to update to Phalcon 4 according to https://docs.phalcon.io/4.0/en/installation but when I execute: sudo apt-get install php7.2-phalcon I get the following message: Reading package lists... Done Building dependency tree
Reading state information... Done Note, selecting 'php7.2-phalcon3' for regex 'php7.2-phalcon' Note, selecting 'php7.2-phalcon4' for regex 'php7.2-phalcon' Note, selecting 'php-phalcon3' instead of 'php7.2-phalcon3' Note, selecting 'php-phalcon4' instead of 'php7.2-phalcon4' php-phalcon3 is already the newest version (3.4.5-2+ubuntu19.10.1+deb.sury.org+1). The following NEW packages will be installed: php-phalcon4 0 upgraded, 1 newly installed, 0 to remove and 169 not upgraded. 1 not fully installed or removed. Need to get 0 B/2.670 kB of archives. After this operation, 18,2 MB of additional disk space will be used. Do you want to continue? [Y/n] Y (Reading database ... 184460 files and directories currently installed.) Preparing to unpack .../php-phalcon4_4.0.2-1+ubuntu19.10.1+deb.sury.org+1_amd64.deb ... Unpacking php-phalcon4 (4.0.2-1+ubuntu19.10.1+deb.sury.org+1) ... dpkg: error processing archive /var/cache/apt/archives/php-phalcon4_4.0.2-1+ubuntu19.10.1+deb.sury.org+1_amd64.deb (--unpack): trying to overwrite '/etc/php/7.2/mods-available/phalcon.ini', which is also in package php-phalcon3 3.4.5-2+ubuntu19.10.1+deb.sury.org+1 dpkg-deb: error: paste subprocess was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/php-phalcon4_4.0.2-1+ubuntu19.10.1+deb.sury.org+1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

can you please provide some help? thanks a lot in advance

edited Jan '20

Hello !

try this :

sudo apt-get install php-phalcon 

Remove php-phalcon3 before installing php-phalcon4: both can't run in parallel.

I did the following:

curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh | sudo bash apt-get install php7.4-phalcon phpenmod phalcon

YMMV