having problem setup Phalcon on a bitnami LAMP VM

hi, I try to follow the official installation guide. I launch a bitnami LAMP virtual machine on Amazon AWS (ubuntu 12 kernel, php 5.4.24). I do have gcc and git. I did: 1. sudo apt-get install php5-dev libpcre3-dev gcc make php5-mysql 2. git clone --depth=1 git://github.com/phalcon/cphalcon.git cd cphalcon/build sudo ./install

  1. create a file 30-phalcon.ini under /etc/php.d/, with content: extension=phalcon.so
  2. restart web server by: sudo /opt/bitnami/ctlscript.sh restart apache

Then I tried a php file simply echo phpinfo(); I saw PHP Version 5.4.24, but no Phalcon in the extensions.

Second, I tried: 5. cd cphalon/build sudo ./install 64bits 6. cd cphalon/build/64bits export CFLAGS="-O2 --fvisibility=hidden" ./configure --enable-phalcon make && sudo make install

Then restart apache same as above, but it won't work either. Any hint? Any trouble shooting procedures?


Try to type php -m in terminal. Check the extension list first. It's nothing to do with your apache.

If you see phalcon in the extension list, and you want to make it active for apache-php-module, then resart your apache.

oh, yes, great! Thanks!