We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Can't install phalcon on ubuntu

The third day I try to establish, it does not work in any way. Is there a step-by-step instruction somewhere that leads to the result? Tell me where to climb, what to watch. Nginx php 7.4 sorry for the stupid question, but there is no one else to turn to



14.3k

I Install on clean ubuntu 20 sudo apt install nginx sudo apt install php I customize nginx as you wrote. Previously, there was some kind of step-by-step instruction that I followed and achieved the goal, everything worked. Now I just can't start invo. What to do next? Unclear. I do something, it doesn't work. I do something else, it also does not work. I've been picking for three days. I reinstall ubuntu. I try again, I can't understand anything.

What does phpinfo() say? Is Phalcon installed? Not being able to install Phalcon is a different problem from not being able to configure nginx, which is a different problem from not being able to run Invo.



14.3k

most likely I do not understand anything about connecting phalcon to php-fpm. PHP-fpm works on nginx, gives the page. I build phalcon from source, write extention = phalcon.io in php.ini phpinfo (); doesn't show phalcon is connected Sorry for the stupidity Explain, please

I have no experience setting up Phalcon with php-fpm or with nginx, so the help I can offer is limited. Perhaps the Discord channel might be more helpful.

From what I can find in Google - are you editing the correct php.ini file? Command-line, FPM, and Apache extension versions of PHP all have their separate php.ini files.

Also, apparently you need to restart FPM after updating the configuration - much like you'd need to restart Apache if changing it's configuration.

https://stackoverflow.com/questions/18617643/php-fpm-wont-load-php-ini-settings



14.3k

Thank you friend! I will do



14.3k

curl -s https://packagecloud.io/install/repositories/phalcon/stable/script.deb.sh | sudo bash

Installing /etc/apt/sources.list.d/phalcon_stable.list...curl: (22) The requested URL returned error: 404 Unable to download repo config from: https://packagecloud.io/install/repositories/phalcon/stable/config_file.list?os=Ubuntu&dist=groovy&source=script



14.3k

there is a feeling that there is no way to establish anything at all. How do you deal with this? After all, this is the simplest thing that even a schoolboy in diapers should do.

You are trying to install on unsupported version of Ubuntu, which is 20.10. Phalcon is supported only for 20.04 at the moment.

Will see if I can make PR today...



14.3k

I installed it somehow. It seems to work. Thank you, guys!



14.3k

Nothing worked for me either on the Ubuntu server or on Windows



14.3k
edited Nov '20

phalcon Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance. phalcon enabled Author Phalcon Team and contributors Version 4.1.0 Build Date Nov 26 2020 19:57:34 Powered by Zephir Version 0.12.19-4345593 Directive Local Value Master Value phalcon.db.escape_identifiers On On phalcon.db.force_casting Off Off phalcon.orm.case_insensitive_column_map Off Off phalcon.orm.cast_last_insert_id_to_int Off Off phalcon.orm.cast_on_hydrate Off Off phalcon.orm.column_renaming On On phalcon.orm.disable_assign_setters Off Off phalcon.orm.enable_implicit_joins On On phalcon.orm.enable_literals On On phalcon.orm.events On On phalcon.orm.exception_on_failed_metadata_save On On phalcon.orm.exception_on_failed_save Off Off phalcon.orm.ignore_unknown_columns Off Off phalcon.orm.late_state_binding Off Off phalcon.orm.not_null_validations On On phalcon.orm.update_snapshot_on_save On On phalcon.orm.virtual_foreign_keys On On phalcon.warning.enable On On

It is give phpinfo(); but no classes from phalcon



4.5k

What does the command below give as output ?

This command shows you are list of all the installed php packages sudo apt list --installed | grep php

and the command

This command shows you are list of all the possible php packages that you an install sudo apt list | grep phalcon