We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

installing vokuro

I try install vokuro

[email protected]:~/www/mysite.ru$ composer install Loading composer repositories with package information Updating dependencies (including require-dev) Your requirements could not be resolved to an installable set of packages.

Problem 1

  • The requested PHP extension ext-phalcon ~4.0.0 has the wrong version (4.1.0) installed. Install or enable PHP's phalcon extension. Problem 2
  • codeception/codeception 4.1.9 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  • codeception/codeception 4.1.8 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  • codeception/codeception 4.1.7 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  • codeception/codeception 4.1.6 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  • codeception/codeception 4.1.12 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  • codeception/codeception 4.1.11 requires ext-curl * -> the requested PHP extension curl is missing from your system.
  • Installation request for codeception/codeception ^4.1.6 -> satisfiable by codeception/codeception[4.1.11, 4.1.12, 4.1.6, 4.1.7, 4.1.8, 4.1.9].

    To enable extensions, verify that they are enabled in your .ini files:

  • /etc/php/7.4/cli/php.ini
  • /etc/php/7.4/cli/conf.d/10-opcache.ini
  • /etc/php/7.4/cli/conf.d/10-pdo.ini
  • /etc/php/7.4/cli/conf.d/15-xml.ini
  • /etc/php/7.4/cli/conf.d/20-calendar.ini
  • /etc/php/7.4/cli/conf.d/20-ctype.ini
  • /etc/php/7.4/cli/conf.d/20-dom.ini
  • /etc/php/7.4/cli/conf.d/20-exif.ini
  • /etc/php/7.4/cli/conf.d/20-ffi.ini
  • /etc/php/7.4/cli/conf.d/20-fileinfo.ini
  • /etc/php/7.4/cli/conf.d/20-ftp.ini
  • /etc/php/7.4/cli/conf.d/20-gettext.ini
  • /etc/php/7.4/cli/conf.d/20-iconv.ini
  • /etc/php/7.4/cli/conf.d/20-json.ini
  • /etc/php/7.4/cli/conf.d/20-mbstring.ini
  • /etc/php/7.4/cli/conf.d/20-phar.ini
  • /etc/php/7.4/cli/conf.d/20-posix.ini
  • /etc/php/7.4/cli/conf.d/20-readline.ini
  • /etc/php/7.4/cli/conf.d/20-shmop.ini
  • /etc/php/7.4/cli/conf.d/20-simplexml.ini
  • /etc/php/7.4/cli/conf.d/20-sockets.ini
  • /etc/php/7.4/cli/conf.d/20-sysvmsg.ini
  • /etc/php/7.4/cli/conf.d/20-sysvsem.ini
  • /etc/php/7.4/cli/conf.d/20-sysvshm.ini
  • /etc/php/7.4/cli/conf.d/20-tokenizer.ini
  • /etc/php/7.4/cli/conf.d/20-xmlreader.ini
  • /etc/php/7.4/cli/conf.d/20-xmlwriter.ini
  • /etc/php/7.4/cli/conf.d/20-xsl.ini You can also run php --ini inside terminal to see which files are used by PHP in CLI mode.

What i must do?

Did you modify your composer.json file? The default requirement for requirement for phalcon is ~4.0.0, which should allow 4.1.0. https://github.com/phalcon/vokuro/blob/master/composer.json

Next, make sure curl is installed. The errors you're getting are for the cli version of PHP, not the FPM version, so you'll need to modify a different php.ini file to make sure extensions are installed.

edited Dec '20

Read the introduction to get some details about this Phalcon sample application: https://blog.phalconphp.com/post/sample-application-vokuro Installing Curl on Windows Make sure php.exe is in the PATH so that it can be executed Install Vokuro's dependencies using Composer. See below for command and log for this activity (assuming Wamp has been installed in D:\Wamp):

D:\Wamp\www\vokuro>C:\phalcon\curl -s http://.org/installer | mcdvoice

!/usr/bin/env php

All settings correct for using Composer Downloading...

Composer successfully installed to: D:\Wamp\www\vokuro\composer.phar Use it: php composer.phar