Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon on Ubuntu Server 12.04 with Apache2 doesn't work

Hello, I am trying to move my phalcon project to my Ubuntu server. I have installed apache 2.2, and php dev the one from the phalcon website. But when I am trying to make a post request I get no response from the server, and inside the error logs from apache I get this error:

[Wed Apr 30 17:00:21 2014] [notice] child pid 18826 exit signal Illegal instruction (4), possible coredump in /etc/apache2

I don't know what to do, we have to luch in a few days and this is really bad for us.

Thank you so much.

Phalcon isn't the problem. Maybe this thread will help you (, if i was you, i will re-install properly your LAMP stack.

Do you think this may be the problem? I've allready reinstalled ubuntu server 3 times. I'm installing each component individual (php, apache, mysql). Do you think that i sould install them as a pack? All toggether like xampp on windows?

edited May '14


I think its seg fault maybe its a problem in phalcon with memory access of frames try to find with valgrind for first gdb dump php with apatch for see the problem

if you don`t see the problem after it you can compile phalcon with debug option

phpize && ./configure CFLAGS="-O2 -g" && make clean && make -B && sudo make install && service php5-fpm restart

and php with +debug option from src

My opinion problem caused in php


First thank for all your answears. I found out what was the problem. The error was caused by the RANDOM ALUMN function from phalcon. I don't know why but on WINDOWS worked perfectly but on UBUNTU gave the error that I posted in my first post.

So if someone will find this problem to, what I've done was to use a php random function and deleted this one. It took me 4 days to find what the problem was, I fucked up 5 servers...

Thank you again!