We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Creating a multi module application


I am trying to create a multi module application. I created a top level project, "myproj" using command line dev tools. It created a directory "1" in the project directory. Can I name modules differently during creation itself. I want names "sales", "invoice" etc. I tried to rename 1 to "sales", then I had to make changes to a lot of files where this was hard coded. I also edited the module.php & config.php file to connect to DB.

  • How do I create the second module, just copy the first module directory or is there way to do it using dev tools.
  • More importantly is this the correct way to go about designing my multi module application. All these modules will run under one directory.
  • What is the use of "frontend", "backend" directories inside apps directory. What functionality should be placed in each.

I am using Phalcon 1.3 and latest Dev Tools. WampServer on Windows platform. I have moderate knowledge of php & MVC architecture. I am in learning phase, coming from Win Client-Server programming background. These are some very basic questions, kindly bear with me.

Regards, Amal


Phalcon Developer Tools does not have an option to rename modules, this would be hard to do because it does not know which files are modified or contain additions so it takes the conservative path to avoid lose the developer work.

"frontend" and "backend" are modules, each one has its own file structure of controllers, models and views.

Follow this example if you have doubts with the structure: https://github.com/phalcon/biko/tree/master/apps


Thanks for your reply. I downloaded biko, unzipped it, created DB, created the tables but when I run it, on http://localhost/biko page it gives me a message "The page you are trying to see does not exist or it was moved". If I click on Software / Hardware / Network menu items it gives me a page with a button "Start Shopping". I click on that and nothing happens. Tried looking around the code but don't know what's the issue. There is no data in the tables though.

Regards, Amal