Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Debian do not recognize extension install

Hi all, i'm like trying Phalcon for first time. I have a Debian Jessie install in my laptop, and try the next installation steps:

1) Clone Phalcon extension from Github and execute "./install". The console output was:

Build complete. Don't forget to run 'make test'.

Installing shared extensions: /usr/lib/php5/20131226/

Thanks for compiling Phalcon! Build succeed: Please restart your web server to complete the installation

2) Add the extension in /etc/php5/cli/conf.d/20-phalcon.ini and /etc/php5/apache2/conf.d/30-phalcon.ini

3) Restart the apache2 and php5-fpm services and look the phpinfo() for check if the extension is loading, and if true.

4) Try to install DevTools via pear but this don't recognize the Phalcon install:

[email protected]:/home/rama/Phalcon# pear install phalcon/Devtools phalcon/Devtools requires PHP extension "phalcon" No valid packages found install failed

Any ideas ?

edited Jul '14

Sorry, I needed to add the extension in /etc/php5/cli/config.d/20-phalcon.ini too.