Building 1.3.3

I do apologize if this is a "learn to use git" question, but I'm at a loss as to what I'm doing wrong.

I'm trying to build 1.3.3 to test the changes that are supposed to fix #2526, but I'm not seeing where 1.3.3 is getting reflected after I build.

I'm on Ubuntu 12.04 64bit.

I have the repo pulled and 1.3.3 checked out. I verified this by checking the last changelog listed on github: 0b77b43f4602c859c4205e98699d902749bf3da5

I verified that I had the extra lines in build/64bits/phalcon.h, which I do.

There are no build errors that I can see, but when I run phpinfo on it, it's still reflecting 1.3.2 from both the CLI and apache after a restart. I dug through /ext/version.c, and PHP_METHOD(Phalcon_Version, _getVersion){ } seems to reflect 1.3.3. The looping fix still doesn't seem to be fixed either, so I figure I'm doing something wrong.

Thanks in advance.


Make sure you're installing Phalcon this way:

git clone
cd cphalcon/build
git checkout 1.3.3
sudo ./install


Yep, that's what I'm doing. Still reflecting 1.3.2. Anything specific you'd like to see?


Did you restart the webserver?


Yes. I also get the same from the CLI.