Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon just not loading anymore

I was doing my project when I did an apache2 restart; and then, magically, cannot be found. What?

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20121212/'


What versions of Linux, Apache, PHP and Phalcon are you using?


12.04 (Server), 2.4.9, 5.5.14 and 1.3.2


I am using Slackware current 64bits, with Apache 2.4.10, PHP 5.4.30 and Phalcon 1.3.2

  • The problem seems to be the lib location!
  • Use php-config --extension-dir to locate the correct path.
  • Use "find / usr-name" to locate the extension and recheck your load line in php.ini

Mine is: extension=/usr/lib64/php/extensions/


I've discovered the fail (anyway thanks for the help; also the find command didn't found anything, even with wildcards); a wrong variable name.

At first I was like "WTF, that results in a not load extension?"; but making another try I've discovered that I don't load the dynamic library never. And all works well. Why?


typo error:

find /usr -name


Ah well, the problem was the other command expression, this works instantly xD