We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

php 5.6.0 gives an error "GET (failed) net::ERR_EMPTY_RESPONSE"


I have updated to php 5.6.0 and every time I try to run my script I got a message of No data and when I check the network response through chrome browser I got this in the column status


I tried to check the error log of apache but everything is ok and there is no problem.

The script was runnig with no problem in the previus version of php 5.5.16.

The problem mainly happend with application type when I tried it with the micro version it's working great

I think it's someting according to this line in public/index.php

echo $application->handle()->getContent();

The method of handle(); as when I commit it everything work again



Try recompile Phalcon extension. Some time it need when PHP updated.

Thank Oleg,

I already recompiled it and I still face the problem.


edited Aug '14

It seems that the problem occurs after registring the volt engine template. throught this method

$di->set('voltService', function($view, $di) {
            $volt = new Volt($view, $di);
                "compiledPath" => "../apps/compiled-templates/",
                "compiledExtension" => ".compiled",
                "compileAlways" => true // remove in production
            return $volt;

After it return the problem occurs.

edited Sep '15

I received error on chrome,

The below commands are working for me,

ipconfig /release

ipconfig /all

ipconfig /flushdns

ipconfig /renew

Source: https://www.wiknix.com/solved-err_empty_response-no-data-received/