Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Permalink error and session error with result Warning: Phalcon\Session\Adapter::start():

Hello, I'm new in phalcon. I try invo to my server. If I open main domain, it can open, but when I click the menu or other link, It still open the index. And, in the top, there is warning error like this : Warning: Phalcon\Session\Adapter::start(): open(/var/lib/php/session/sess_mmkd70nmse5ttq8enve5jbutg7, O_RDWR) failed: Permission denied (13) in /var/www/ on line 117 I use nginx as the webserver, already tried the config in the documentation, still didn't work Please need advise for both errors :-)


This means the current OS user that runs the nginx process does not have permissions to write in the /var/lib/php/session/ directory


About permisions, actually I already change it to 777 in session directory, but I will try it again. How about the first one? All link just open the same page ..


Update : About the permisions, already solved.

Now about the permalink. even though I click register, about, etc, it still show the first page.

I have a feeling it about nginx/vhost config