Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

install on ubutu 14.04 LTS

Hi everyone,
I install phalcon ok, but htaccess file seem not execute.
Exam: type "localhost/invo" => it is not run.
type "localhost/invo/public" => it is run.
the file: /etc/apache2/sites-available/default is

<Directory /var/www/html>
          Options Indexes FollowSymLinks MultiViews                                
          AllowOverride All                                                   
          Order allow,deny                                      
          allow from all                                             

and /var/www/html/invo/.htaccess is

<IfModule mod_rewrite.c>
   RewriteEngine on                           
   RewriteRule  ^$ public/    [L]                                  
   RewriteRule  (.*) public/$1 [L]                           

I have check mod_rewrite, it is already enable
Help me please.



check if mod_rewrite is enabled


Yeah, your server root starts from localhost. So you don't access automatically public by writting invo in the URL. You need to set up a virtual server, whose root is /var/www/invo/public, set a ServerName (like and modify your /etc/host/ file to add that virtual server (located in localhost).

I think that's the issue.