Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon 1.3 on Yosemite

before this day I'm using Phalcon 1.3 on Maverick and It's working pretty fly. After update OS X to Yosemite is gone away.

I try to re-install with basic way as below

git clone git://
cd cphalcon/build
sudo ./install

but It's hurt me with error

checking dynamic linker characteristics... gcc: warning: couldn't understand kern.osversion '14.0.0
darwin14.0.0 dyld
make: *** [phalcon.lo] Error 1

Does anyone upgrade OS X to 10.10 and still working with Phalcon?


Not sure what's the error, but I'm running yosemite and phalcon works perfect.


Maybe XCode must be updated


I found the solution.

OS X 10.10 come with gcc 4.8.3
when try to install phalcon I found error

gcc: warning: couldn't understand kern.osversion '14.0.0

The solution is

  • upgrade gcc to newer version (4.9.1)
  • re-install phalcon