We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Cannot install phalcon on Centos/Apache2.4/PHP5.5.17

I go this error:

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/local/lib/php/extensions/no-debug-zts-20121212/phalcon.so' - /usr/local/lib/php/extensions/no-debug-zts-20121212/phalcon.so: undefined symbol: output_globals in Unknown on line 0

I also tried to do these:

  • cd cphalcon/build/64bits
  • make clean
  • phpize --clean
  • find / -name phpize
  • /path/to/phpize
  • find / -name php-config
  • ./configure --with-php-config=/path/to/php-config
  • make
  • make install

But nothing useful, still cannot enable the module. Anyone can let me know what should I fix?


Tri Nguyen


Are you adding extension=phalcon.so directly to php.ini? Maybe as in Ubuntu, it needs a file of its own. Something like /etc/php.d/phalcon.ini

I tried to create a phalcon.ini in /etc/php.d/ also and no more errors, but the module never been initilized or called. php -m | grep phalcon returns empty.