Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Intermittent Phalcon\Mvc\Model\Exception in Vagrant Machine

Hi all,

Not sure what's going on at the moment. I'm running Phalcon 1.3.3 on a CentOS vagrant box with php 5.6 and I'm getting messages like:

Phalcon\Mvc\Model\Exception: Column 'status' doesn't belong to any of the selected models (1), when preparing: SELECT [Orders].* FROM [Orders] WHERE status = "complete" ORDER BY updated DESC LIMIT 300

If I refresh a few times it works again. I'm leaning towards an APC problem but I wondered if anyone has seen this behaviour before before I start spending hours trying to slove the problem.

Regards :)


Update. Removing

    $di->set('modelsMetadata', function(){
        $MetatData = new \Phalcon\Mvc\Model\Metadata\Apc([
                'lifetime' => 10,
                'prefix' => "arion"
        return $MetatData;

Has stopped the error messages.