External Library ok in WAMP environment, but not in LEMP


I recently moved my app from development(WAMP) to production environmnent(LEMP). I am facing some configration issues. In my app, i have set phalcon to autoload external libraries. It is working fine in WAMP, but not in LEMP. I have this class not found Error

The external library i am using is Sendgrid Api.

This is how i set phalcon to autoload the libraries.

1) Config.php Add the libraryDir path

    return new \Phalcon\Config(array(
              'application' => array(
              'controllersDir' => __DIR__ . '/../../app/controllers/',
              'modelsDir'      => __DIR__ . '/../../app/models/',
              'viewsDir'       => __DIR__ . '/../../app/views/',
              'pluginsDir'     => __DIR__ . '/../../app/plugins/',
              'libraryDir'     => __DIR__ . '/../../app/library/',
              'cacheDir'       => __DIR__ . '/../../app/cache/',
              'baseUri'        => '/',

2) Loader.php - Register the directories


3) Calling it in the controllers

     function sendEmail($emailaddress,$name,$message,$toemail){
            $sendgrid = new SendGrid($this->config->sendgrid->username, $this->config->sendgrid->password,$this->config->sendgrid->options);
            $email  = new SendGrid\Email();

My library folder resides in app folder.

Any help appreciated! The weird thing is that i do not know why it is working fine in WAMp but not in LEMP


Please checking filename directory is lowercase or upcase , linux is discrimination lowercase betwent upcase



Renamed directory to lowercase but didnt have.

I am thinking that it might be an issue with namespaces. what do you think?


That right , you tried autoload used namespace not using Register the directories

edited Nov '14

i tried autoloading namespaces, but does not work. Is my path wrong>?

//Register some namespaces
    'SendGrid\Email' => 'SendGrid/',
    'SendGrid\Smtpapi' => 'Smtpapi/',
    'SendGrid\Unirest' => 'Unirest/'

Here is my library file structure. i have a folder called library inside app folder.

edited Nov '14

Not correct , i don't see full source your so i can't help you, but you refer to https://github.com/phalcon/vokuro/blob/master/app/config/loader.php

    'SendGrid' => ROOT. 'SendGrid/',

You don't even describe the problem you're having? Just that it worked fine on Windows but not on Linux doesn't help us to help you.


Hi Rewt0r, thanks for the reply. I am stucked on finding out what is the issue too. As you can see from previous post, suspected that it might be the namespace issue. Will keep u guys updated.