We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Build fails on CentOS 7 64bit (500MB vps)

Hi

I can't build phalcon on CentOS 7 64bit (digitalocean, 500MB droplet).

When I run ./install it does all the checks, then gets to: libtool: compile: gcc -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC ... and stays there for about twenty minutes, then says:

gcc: internal compiler error: Killed (program cc1) Please submit a full bug report, with preprocessed source if appropriate. See http://bugzilla.redhat.com/bugzilla for instructions. make: *** [phalcon.lo] Error 1

(I couldn't get the second code block to work in markdown)

I ran yum update, installed all the dependencies in the docs, and tried checking out branch 1.3.3. I tried the manual build in the docs too, same result.

Maybe 500MB is not enough memory? Any other ideas?



4.5k
Accepted
answer

Solved! I added a 2G swapfile and phalcon built in about 5 seconds :)