We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Initial project not quite working

The saga continues:

I have a lamp stack running in an ubuntu vm, the phalcon module seems to be correctly installed as are the devtools.

I have created a basic project like this: ```bash [email protected]:/var/www$ phalcon project new

Phalcon DevTools (1.1.0)
Success: Controller "index" was successfully created.
Success: Project "new" was successfully created.



but when I access from a browser I get an error 500 returned, in the /var/log/apache2/error.log I get:

```bash PHP Fatal error:  Class 'Phalcon\\Config' not found in /var/www/hello/app/config/config.php on line 3```

This is a vanilla lamp installation, do I need to set a classpath somewere?


98.9k

It seems the extension is not correctly loaded, check in your phpinfo() what is the path to the php.ini and add "extension=phalcon.so" at the end of that file



11.2k
Accepted
answer

Problem solved, Ubuntu has a separate php.ini file for the cli and apache2 - I had only added it to the cli one. Thanks.