Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon PPA Install on Ubuntu Server 14.04.1 LTS Fails

When using ppa to install phalcon I get this message; (this is on DigitalOcean vps) PHP version used 5.6.4

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 php5-phalcon : Depends: phpapi-20121212+lfs
                Recommends: php-apc or
                            php5-xcache but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Looks like it requires an opcache extension. Since you are using 5.6 try

$     sudo apt-get install php5-xcache


You can't. Official PPA does not supprot 5.6 now.



Thanks guys, I got it working by compiling it manually :-)