Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Segmentation fault (core dumped)

I'm trying to compile phalcon from source and at the end when I add it to php config it doesn't appear in settings I try to run it by "/usr/lib/php5/20121212/" and i get "Segmentation fault (core dumped)" Same thing I get after I compile phalcon 2 with zephir



You can't run as it is a simple executable program, because is a shared library that is loaded by php itself.

How to solve your problem:

1/ first check if phalcon is correctly loaded by php: in your webroot, create a info.php file with <?php phpinfo(); ?>, open that file in your browser and see if phalcon is there.

2/ if not: Check that phalcon is declared in your php.ini or if your using debian or some kind of derivated distribution create a /etc/php5/conf.d/30-phalcon.ini file with in it. Make a "service apache2 restart"

3/ Have a look at /var/log/apache2/error.log if phalcon isn't loaded.

ah.. you are right. I didn't knew that I had to put it in "/etc/php5/fpm/conf.d/20-phalcon.ini" too and not only in "/etc/php5/fpm/php.ini". Now it works fine. Thank you.