Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Phalcon installation not working in debian 7 after Php upgrade


I recently upgrade my php5.4 install ( where phalcon extension was working ) to php5.5, but since I can't make phalcon extension work. I reinstalled it following the official page ( ), created the 30-phalcon.ini file in /etc/php5/conf.d/ and restarted the server, but it still the same. I searched on the forum and tried many things but php does not seem to recognize the extension.

I'm using Apache2.

When upgrading php in Debian, it may also overwrite your php.ini file. Your php.ini file needs to have a line like, which won't exist in the default php.ini file.

Thanks for your answer !

Unfortunatly I still have this issue. I added extension=/usr/lib/php5/20100525/ to the php.ini located at /etc/php5/apache2 and restarted apache2 but nothing change.


Make sure to upgrade also php5-dev package before recompiling. Check your /var/log/apache2/errors.log after restarting your apache server you might find an hint

Thank you so much, it works ! The issue cames from the php5-dev package who was not upgraded ! Your hint was good too, the error.log was showing that error:

PHP Warning: PHP Startup: phalcon: Unable to initialize module\nModule compiled with module API=20100525\nPHP compiled with module API=20121212\nThese options need to match\n in Unknown on line 0

Thank you the Phalcon community for having solved my problem :)


I lost so much time too with this issue, I guess documentation should be edited to notice this fact.