Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Trouble compiling phalcon in ubuntu 12.10

Hi I've compiled successfully phalcon 0.9.0. But the second time I tried to compile phalcon, the compilers stop because of error. I am using ubuntu 12.10 & gcc 4.7.2

Here is the command:

git clone --branch=0.9.1 git://
cd cphalcon/build
sudo ./install

Here is the output error

config.status: creating config.h
config.status: executing libtool commands
/bin/bash /root/cphalcon/build/64bits/libtool --mode=compile gcc  -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib  -DHAVE_CONFIG_H  -march=native -mtune=native -O2 -fno-delete-null-pointer-checks -finline-functions -fomit-frame-pointer   -c /root/cphalcon/build/64bits/phalcon.c -o phalcon.lo
libtool: compile:  gcc -I. -I/root/cphalcon/build/64bits -DPHP_ATOM_INC -I/root/cphalcon/build/64bits/include -I/root/cphalcon/build/64bits/main -I/root/cphalcon/build/64bits -I/usr/include/php5 -I/usr/include/php5/main -I/usr/include/php5/TSRM -I/usr/include/php5/Zend -I/usr/include/php5/ext -I/usr/include/php5/ext/date/lib -DHAVE_CONFIG_H -march=native -mtune=native -O2 -fno-delete-null-pointer-checks -finline-functions -fomit-frame-pointer -c /root/cphalcon/build/64bits/phalcon.c  -fPIC -DPIC -o .libs/phalcon.o
/root/cphalcon/build/64bits/phalcon.c: In function 'phalcon_escape_html':
/root/cphalcon/build/64bits/phalcon.c:7007:2: warning: passing argument 3 of 'php_escape_html_entities' from incompatible pointer type [enabled by default]
In file included from /root/cphalcon/build/64bits/phalcon.c:176:0:
/usr/include/php5/ext/standard/html.h:57:14: note: expected 'size_t *' but argument is of type 'unsigned int *'
gcc: internal compiler error: Killed (program cc1)
Please submit a full bug report,
with preprocessed source if appropriate.
See <file:///usr/share/doc/gcc-4.7/README.Bugs> for instructions.
make: *** [phalcon.lo] Error 1

Any solution?


hi, This is happening because the virtual machine/server does not have enough memory to complete the operation then the OS is killing the process.

Oops, the memory is depleted. You're correct :)