We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

Problems on Ubuntu Server 14.04

When I execute the command sudo apt-get install php5-phalcon I just get this error (I used Google translate, but you'll get the idea):

Failed to install some packages. This may mean that
requested an impossible situation or if you are using the distribution
distribution that some required packages have not yet been created or been
been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5-Phalcon: Depends: 20121212 + lfs-phpapi
                 Recommends: php-apc or
                             php5-xcache but it will not be installed
E: We were unable to correct problems, you have held broken packages.

I never had this issue before. PHP is 5.6 (but also with 5.5).

edited Mar '15


The repository doesn't support php 5.6, only php 5.5. You could try to remove php5 with '--purge' option and reinstall. Or compile phalcon php from source and this way will work for php 5.6 too.


or for 2.0


after you compile it, add to 'php.ini' and to '/etc/php5/apache2/conf.d/30-phalcon.ini'



I discovered that the problem is using ondrej PPA repository on Ubuntu Server 14.04 from what I've been reading.

Getting back to 12.04 it seems...

edited Apr '15

that's odd

That's the ppa that I'm using and it works without problems


This shouldn't be a reason to downgrade to 12.04. Compiling from source is straight forward, easy to do and it takes just a few minutes