Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

phalcon 2 : func_get_arg(): Argument 2 not passed to function


Plz I need some help

a while ago I installed Phalcon version 1.3 and was able to programming without any problems. After a while I update the program to version 2.0.0 and thwn I get this Error message:

func_get_arg(): Argument 2 not passed to function

Moreover, using forms when you write somethings wrong and you get back to firstpage, then the page's Csrf disappears and an error message comes up


/Regards Belal


Are you using gettext?

Could you please compile from the 2.0.x branch?

cd cphalcon
git checkout 2.0.x
cd ext
sudo ./install

I using Windows and xampp

Did you install gcc, make, libtool, automake, etc?

I solve my problem now with NativeArray

But my problem is not solved with csrf

How to solve it?

Could you please post the code that allow us to reproduce the issue of csrf?

Thank you very much