We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

Phalcon on Solaris

I compile PHP (latest - 5.6.8) and Phalcon from source. php -m shows me Phalcon is installed/phpinfo() page shows same.

I create a sample project using devtools and try to run with PHP dev server (php -S) and get core dump on index page load every time.

I always tried with Phalcon 1.4 compiled source, same result.

Can post more details if relevant.



I didn't use solaris since I was student (long time ago now !), But on my debian boxes some tweaks were necessary to load correctly phalcon:

  • do not load phalcon from within php.ini

  • load phalcon with /etc/php5/apache2/conf.d/90-phalcon.ini (so that it is loaded after the needed lib, you may find the right configuration file for solaris)

Hmm I'd rather see if I can get phalcon working using php dev server i.e. I don't have apache running. Will have to compile apache from src as well.

Will see about doing that tomorrow and if it makes a difference using through mod-php? Although I can't imagine why since mod-php would be loading same interpreter I am trying to use.