We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

phalco.so unable to load

Hi All,

Permission to posts.

I am using to FedoraCore21 and tried to install phalcon.

I follow the instructions:

yum install php-devel pcre-devel gcc make Loaded plugins: langpacks Package php-devel-5.6.8-1.fc21.x86_64 already installed and latest version Package pcre-devel-8.35-11.fc21.x86_64 already installed and latest version Package gcc-4.9.2-6.fc21.x86_64 already installed and latest version Package 1:make-4.0-3.fc21.x86_64 already installed and latest version Nothing to do


  1. To create the extension from C source follow these steps: git clone --depth=1 git://github.com/phalcon/cphalcon.git cd cphalcon/build sudo ./install

Add the extension to your php.ini:

extension=phalcon.so I added to the last line of my php.ini

and did restart my httpd.

I check the loaded library but phalcon.so is not loaded.



Sorry Guys for my impatient on old posts re: phalcon extension not loading...

I tried to add 30-phalcon.ini at /etc/php.d/ and restart my apache and phalcon extension was already loaded.

Thanks for old posts.