We have moved our forum to GitHub Discussions. For questions about Phalcon v3/v4/v5 you can visit here and for Phalcon v6 here.

Blank page, half the time

Hello, I got a problem with Phalcon. I got a AdminController, with a usersAction() in it (to use /admin/users) but the only problem is, the page loads, when i use a post on the page (see https://gist.github.com/KindlyFire/d70b333b5dccb3eb97a9 ) it doesn't work, but only with the "ban". Also, why does main page loads on local but not at all on my server ? Phalcon is installed correctly and /beta and /beta/register also works. Something also, Phalcon isn't verbose at all in log file.

Also note, i got 2.0.1 on my computer and 2.0.3 on me server.

Check server logs. But the real problem is that you are storing raw passwords and then sha1... you should use bcrypt

I know that, and i did it because i was gonna migrate passwords to another database later (and i was hesitating between sha1/bcrypt). I solved the problem, everything routes fine now, only the View that doesnt load.

If i put a echo 'Test'; in the function indexAction() in file /app/controllers/User/MeController.php (namespace Kandles\Controllers\User) it shows up. But when i put that in a view (/app/view/user/me/index.volt) it doesnt. Not in /app/view/user/me/index.volt either. Where is the problem ?

Try renaming the view to /app/view/User/Me/index.volt

Did that, not working :/

Turn on error_reporting and check your server logs to see what is the error

Nothing at all, Phalcon isn't verbose at all

Dump the view object and check if the paths are the expected

edited Jun '15


Looks like it search for /app/views/index.volt , but why ? (btw not loading main view either, bc it doesnt exists)

(P.S. for now, i manually use $this->view->pick() bc that solves it, but i don't like that)

Sorry, try with /app/view/Me/index.volt not with /app/view/User/Me/index.volt as previously I've written

Still not working... :/

Really disappointing... subscribe to view:notFoundView event (https://github.com/phalcon/cphalcon/blob/master/phalcon/mvc/view.zep#L670) and check the path