Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

Installation issue : PHP 5.6


I struggling install Phalcon for 2 days but still fail. my server has lasted Direct Admin installed.

below is my installation command

cd /root/cphalcon/ext && /usr/local/php56/bin/phpize --clean && /usr/local/php56/bin/phpize && ./configure --enable-phalcon --with-php-config=/usr/local/php56/bin/php-config56 && make

which generate error in config.log as below

please suggest how to fix this

Thank so much in advanced.


This file contains any messages produced by compilers while running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was generated by GNU Autoconf 2.63. Invocation command line was

$ ./configure --enable-phalcon




hostname = hidden uname -m = x86_64 uname -r = 2.6.32-504.23.4.el6.x86_64 uname -s = Linux uname -v = #1 SMP Tue Jun 9 20:57:37 UTC 2015

/usr/bin/uname -p = unknown /bin/uname -X = unknown

/bin/arch = x86_64 /usr/bin/arch -k = unknown /usr/convex/getsysinfo = unknown /usr/bin/hostinfo = unknown /bin/machine = unknown /usr/bin/oslevel = unknown /bin/universe = unknown

PATH: /usr/local/sbin PATH: /usr/local/bin PATH: /sbin PATH: /bin PATH: /usr/sbin PATH: /usr/bin PATH: /root/bin


Core tests.


configure:1984: checking for grep that handles long lines and -e configure:2044: result: /bin/grep configure:2049: checking for egrep configure:2113: result: /bin/grep -E configure:2118: checking for a sed that does not truncate output configure:2184: result: /bin/sed configure:2318: checking for cc configure:2334: found /usr/bin/cc configure:2345: result: cc configure:2379: checking for C compiler version configure:2387: cc --version >&5 cc (GCC) 4.4.7 20120313 (Red Hat 4.4.7-11) Copyright (C) 2010 Free Software Foundation, Inc. This is free software; see the source for copying conditions. There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:2391: $? = 0 configure:2398: cc -v >&5 Using built-in specs. Target: x86_64-redhat-linux Configured with: ../configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info --with-bugurl= --enable-bootstrap --enable-shared --enable-threads=posix --enable-checking=release --with-system-zlib --enable-__cxa_atexit --disable-libunwind-exceptions --enable-gnu-unique-object --enable-languages=c,c++,objc,obj-c++,java,fortran,ada --enable-java-awt=gtk --disable-dssi --with-java-home=/usr/lib/jvm/java-1.5.0-gcj- --enable-libgcj-multifile --enable-java-maintainer-mode --with-ecj-jar=/usr/share/java/eclipse-ecj.jar --disable-libjava-multilib --with-ppl --with-cloog --with-tune=generic --with-arch_32=i686 --build=x86_64-redhat-linux Thread model: posix gcc version 4.4.7 20120313 (Red Hat 4.4.7-11) (GCC) configure:2402: $? = 0 configure:2409: cc -V >&5 cc: '-V' option must have argument configure:2413: $? = 1 configure:2436: checking for C compiler default output file name configure:2458: cc -O2 --fvisibility=hidden conftest.c >&5 cc1: error: unrecognized command line option "-ffvisibility=hidden" configure:2462: $? = 1 configure:2500: result: configure: failed program was: / confdefs.h. / #define PACKAGE_NAME "" #define PACKAGE_TARNAME "" #define PACKAGE_VERSION "" #define PACKAGE_STRING "" #define PACKAGE_BUGREPORT "" / end confdefs.h. /
main ()
return 0;

configure:2506: error: in /root/cphalcon/build/64bits': configure:2509: error: C compiler cannot create executables Seeconfig.log' for more details.


I'm done. below is checklist to solve my issue before installation,

you should check what your current php version on your server by run "php -v"

1. if you server install multiple version of php, make sure you run the same version between "phpize" and "php-config"

cd /root/cphalcon/ext && [path to phpize] && ./configure --enable-phalcon --with-php-config=[paht to php-config] && make && make install

in my case

cd /root/cphalcon/ext && /usr/local/php56/bin/phpize --clean && /usr/local/php56/bin/phpize && ./configure --enable-phalcon --with-php-config=/usr/local/php56/bin/php-config56 && make && make install

2. config php.ini ( make sure you edit correct file ) add line "extension=[absolute path to]" or extension_dir = "[path to extension directory]" extension = ""

in my case : "extension=/usr/local/php56/lib/php/extensions/no-debug-non-zts-20131226/"

3. file ownership - directory related to phalcon might be "/usr/root/phalcon", "/usr/local/php56/include/php/ext/phalcon" . for me i set to 755