We are moving our forum in GitHub Discussions. For questions about Phalcon v3/v4 you can visit here and for Phalcon v5 here.

Solved thread

This post is marked as solved. If you think the information contained on this thread must be part of the official documentation, please contribute submitting a pull request to its repository.

WAMP - [solved]

WAMP server components are compiled using VC9 only for PHP 5.4.3, but there is no Phalcon binary for this php version. I've tried the latest binaries, but to no avail. Apache starts but an error is logged: "PHP Warning: PHP Startup: in Unknown on line 0".


In my local developer's server I now have php 5.4.9 compiled with VC9 (downloaded from php.net) and phalcon from phalcon's site and all works fine. I have used VC9 version all the time while using phalcon. I don't think this is the issue. Do all work fine without phalcon extention?


All is working fine, yes.

Now, I'm using x64 version of WAMP. Going to github and checking old file of phalconphp website, I have found phalcon_x64_VC9_php5.4.0_0.5.1.zip. Using this dll, the error that now appears is:

PHP Warning: PHP Startup: phalcon: Unable to initialize module Module compiled with build ID=API20100525,TS,VC10 PHP compiled with build ID=API20100525,TS,VC9 These options need to match

The ZIP file on the download area of the site is compiled with PHP 5.4.9. It is the x86 version and not the x64. Since PHP is not pure 64 bit we have not pursued that avenue lately.

Check if that works for you - in the meantime I will try and compile some 64 bit ones.

As for the 0.5.1 version I would not recommend it since there is a ton of functionality between that version and 0.9


The first thing I did was to try the file at the download area, but it does not work with x64 version of WAMP/PHP. I guess the best choice is probably to uninstall this version and go with x86 for local development with Windows machines... Meanwhile, if you do find time to compile some x64, please let me know. Thank you.


I've Installed WAMP x86 with PHP 5.4.3 and have used phalcon from the download area - problem solved. Thank you.


Can you please go here: https://github.com/niden/website/tree/master/public/files and download either of the x64 DLLs compiled and see if it works for you?

If it does, then we can include those in the download area.



Sorry, but those x64 files are empty (1KB)

Ack! Apologies for that. I must have pushed the wrong zip files.

Kindly check again. I just pushed a fresh set.



Just tried with PHP 5.4.3 (API20100525,TS,VC9) from wampserver 2.2 x64 and it worked just fine! Thank you again.